CVE-2021-32644

Cross-site Scripting in Random.php

MEDIUM
5.4
CVSS Score
Published: June 22, 2021 at 05:45 PM UTC
Updated: June 17, 2026 at 03:53 AM UTC
1 product affected across 1 vendorAmpache

Using ampache by ampache?

Get instant alerts when new vulnerabilities affect ampache - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.8%

Description

Ampache is an open source web based audio/video streaming application and file manager. Due to a lack of input filtering versions 4.x.y are vulnerable to code injection in random.php. The attack requires user authentication to access the random.php page unless the site is running in demo mode. This issue has been resolved in 4.4.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.4.34.4.2
Affected range stops below 4.4.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card