CVE-2021-31383

Junos OS and Junos OS Evolved: In Point to MultiPoint (P2MP) scenarios receipt of various crafted packets causes RPD to core.

HIGH
7.5
CVSS Score
Published: October 19, 2021 at 06:17 PM UTC
Updated: June 17, 2026 at 03:51 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%

Description

In Point to MultiPoint (P2MP) scenarios within established sessions between network or adjacent neighbors the improper use of a source to destination copy write operation combined with a Stack-based Buffer Overflow on certain specific packets processed by the routing protocol daemon (RPD) of Juniper Networks Junos OS and Junos OS Evolved sent by a remote unauthenticated network attacker causes the RPD to crash causing a Denial of Service (DoS). Continued receipt and processing of these packets will create a sustained Denial of Service (DoS) condition. This issue affects: Juniper Networks Junos OS 19.2 versions prior to 19.2R3-S2; 19.3 versions prior to 19.3R2-S6, 19.3R3-S2; 19.4 versions prior to 19.4R1-S4, 19.4R2-S4, 19.4R3-S3; 20.1 versions prior to 20.1R2-S2, 20.1R3; 20.2 versions prior to 20.2R2-S3, 20.2R3; 20.3 versions prior to 20.3R2. This issue does not affect Juniper Networks Junos OS versions prior to 19.2R1. Juniper Networks Junos OS Evolved 20.1 versions prior to 20.1R3-EVO; 20.2 versions prior to 20.2R3-EVO; 20.3 versions prior to 20.3R2-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 19.2R1 (unaffected)
Affected range stops below 19.2R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.3R2-S6, 19.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.4R1-S4, 19.4R2-S4, 19.4R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.1R2-S2, 20.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R2-S3, 20.2R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R2, so it looks safe — our inference, not a vendor statement
20.1 ≤ v < 20.1R3-EVO20.2 ≤ v < 20.2R3-EVO20.3 ≤ v < 20.3R2-EVO20.120.220.3
Affected range stops below 20.1R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA11251

CVSS

7.5HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-121CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card