CVE-2021-31353

Junos OS and Junos OS Evolved: RPD core upon receipt of specific BGP update

HIGH
7.5
CVSS Score
Published: October 19, 2021 at 06:16 PM UTC
Updated: June 17, 2026 at 03:51 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%

Description

An Improper Handling of Exceptional Conditions vulnerability in Juniper Networks Junos OS and Junos OS Evolved allows an attacker to inject a specific BGP update, causing the routing protocol daemon (RPD) to crash and restart, leading to a Denial of Service (DoS). Continued receipt and processing of the BGP update will create a sustained Denial of Service (DoS) condition. This issue affects very specific versions of Juniper Networks Junos OS: 19.3R3-S2; 19.4R3-S3; 20.2 versions 20.2R2-S3 and later, prior to 20.2R3-S2; 20.3 versions 20.3R2 and later, prior to 20.3R3; 20.4 versions 20.4R2 and later, prior to 20.4R3; 21.1 versions prior to 21.1R2. Juniper Networks Junos OS 20.1 is not affected by this issue. This issue also affects Juniper Networks Junos OS Evolved: All versions prior to 20.4R2-S3-EVO, 20.4R3-EVO; 21.1-EVO versions prior to 21.1R2-EVO; 21.2-EVO versions prior to 21.2R2-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 19.3R3-S2 (unaffected)
Vendor states this is fixed in 20.1R1 (unaffected)
Vendor states this is fixed in 20.2 (unaffected)
Vendor states this is fixed in 20.3 (unaffected)
Vendor states this is fixed in 20.4 (unaffected)
Affected range stops below 21.1R2, so it looks safe — our inference, not a vendor statement
v < 20.4R2-S3-EVO, 20.4R3-EVO21.1-EVO ≤ v < 21.1R2-EVO21.2-EVO ≤ v < 21.2R2-EVO21.1-EVO21.2-EVO
Affected range stops below 20.4R2-S3-EVO, 20.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMExploitMitigationVendor Advisory
https://kb.juniper.net/JSA11218

CVSS

7.5HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-755

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card