CVE-2021-31350

Junos OS and Junos OS Evolved: Privilege escalation vulnerability in Juniper Extension Toolkit (JET)

HIGH
8.8
CVSS Score
Published: October 19, 2021 at 06:16 PM UTC
Updated: June 17, 2026 at 03:51 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.9%

Description

An Improper Privilege Management vulnerability in the gRPC framework, used by the Juniper Extension Toolkit (JET) API on Juniper Networks Junos OS and Junos OS Evolved, allows a network-based, low-privileged authenticated attacker to perform operations as root, leading to complete compromise of the targeted system. The issue is caused by the JET service daemon (jsd) process authenticating the user, then passing configuration operations directly to the management daemon (mgd) process, which runs as root. This issue affects Juniper Networks Junos OS: 18.4 versions prior to 18.4R1-S8, 18.4R2-S8, 18.4R3-S8; 19.1 versions prior to 19.1R2-S3, 19.1R3-S5; 19.2 versions prior to 19.2R1-S7, 19.2R3-S2; 19.3 versions prior to 19.3R2-S6, 19.3R3-S2; 19.4 versions prior to 19.4R1-S4, 19.4R2-S4, 19.4R3-S3; 20.1 versions prior to 20.1R2-S2, 20.1R3; 20.2 versions prior to 20.2R2-S3, 20.2R3; 20.3 versions prior to 20.3R2-S1, 20.3R3; 20.4 versions prior to 20.4R2. This issue does not affect Juniper Networks Junos OS versions prior to 18.4R1. Juniper Networks Junos OS Evolved: All versions prior to 20.4R2-EVO; 21.1-EVO versions prior to 21.1R2-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 18.4R1 (unaffected)
Affected range stops below 18.4R1-S8, 18.4R2-S8, 18.4R3-S8, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.1R2-S3, 19.1R3-S5, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.2R1-S7, 19.2R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.3R2-S6, 19.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.4R1-S4, 19.4R2-S4, 19.4R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.1R2-S2, 20.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R2-S3, 20.2R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R2-S1, 20.3R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R2, so it looks safe — our inference, not a vendor statement
v < 20.4R2-EVO21.1-EVO ≤ v < 21.1R2-EVO21.1-EVO
Affected range stops below 20.4R2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMPatchVendor Advisory
https://kb.juniper.net/JSA11215

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card