CVE-2021-3062

PAN-OS: Improper Access Control Vulnerability Exposing AWS Instance Metadata Endpoint to GlobalProtect Users

HIGH
8.8
CVSS Score
Published: November 10, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 04:04 AM UTC
2 products affected across 1 vendorPAN-OSVm-Series Firewall

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.7%

Description

An improper access control vulnerability in PAN-OS software enables an attacker with authenticated access to GlobalProtect portals and gateways to connect to the EC2 instance metadata endpoint for VM-Series firewalls hosted on Amazon AWS. Exploitation of this vulnerability enables an attacker to perform any operations allowed by the EC2 role in AWS. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20 VM-Series firewalls; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11 VM-Series firewalls; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14 VM-Series firewalls; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8 VM-Series firewalls. Prisma Access customers are not impacted by this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.0.810.0.0 ≤ v < 10.0.88.1 ≤ v < 8.1.208.1.0 ≤ v < 8.1.209.0 ≤ v < 9.0.149.0.0 ≤ v < 9.0.149.1 ≤ v < 9.1.119.1.0 ≤ v < 9.1.1110.08.19.09.1
Affected range stops below 10.0.8, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 10.1.* (unaffected)
Affected range stops below 8.1.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.11, so it looks safe — our inference, not a vendor statement
paloaltonetworks-vm-series-firewall (environment)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-284NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card