CVE-2021-3060

PAN-OS: OS Command Injection in Simple Certificate Enrollment Protocol (SCEP)

HIGH
8.1
CVSS Score
Published: November 10, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 04:04 AM UTC
2 products affected across 1 vendorPAN-OSPrisma Access

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 33%

Description

An OS command injection vulnerability in the Simple Certificate Enrollment Protocol (SCEP) feature of PAN-OS software allows an unauthenticated network-based attacker with specific knowledge of the firewall configuration to execute arbitrary code with root user privileges. The attacker must have network access to the GlobalProtect interfaces to exploit this issue. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20-h1; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14-h3; PAN-OS 9.1 versions earlier than PAN-OS 9.1.11-h2; PAN-OS 10.0 versions earlier than PAN-OS 10.0.8; PAN-OS 10.1 versions earlier than PAN-OS 10.1.3. Prisma Access customers with Prisma Access 2.1 Preferred and Prisma Access 2.1 Innovation firewalls are impacted by this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.0.810.0.0 ≤ v < 10.0.810.1 ≤ v < 10.1.310.1.0 ≤ v < 10.1.38.1 ≤ v < 8.1.20-h18.1.0 ≤ v ≤ 8.1.209.0 ≤ v < 9.0.14-h39.0.0 ≤ v ≤ 9.0.149.1 ≤ v < 9.1.11-h29.1.0 ≤ v ≤ 9.1.1110.010.18.19.09.1
Affected range stops below 10.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.1.20-h1, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.14-h3, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.11-h2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.2* (unaffected)

CVSS

8.1HIGHpalo_alto
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card