CVE-2021-3056

PAN-OS: Memory Corruption Vulnerability in GlobalProtect Clientless VPN During SAML Authentication

HIGH
8.8
CVSS Score
Published: November 10, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 04:04 AM UTC
2 products affected across 1 vendorPAN-OSPrisma Access

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%

Description

A memory corruption vulnerability in Palo Alto Networks PAN-OS GlobalProtect Clientless VPN enables an authenticated attacker to execute arbitrary code with root user privileges during SAML authentication. This issue impacts: PAN-OS 8.1 versions earlier than PAN-OS 8.1.20; PAN-OS 9.0 versions earlier than PAN-OS 9.0.14; PAN-OS 9.1 versions earlier than PAN-OS 9.1.9; PAN-OS 10.0 versions earlier than PAN-OS 10.0.1. Prisma Access customers with Prisma Access 2.1 Preferred firewalls are impacted by this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.0.18.1 ≤ v < 8.1.208.1.0 ≤ v < 8.1.209.0 ≤ v < 9.0.149.0.0 ≤ v < 9.0.149.1 ≤ v < 9.1.99.1.0 ≤ v < 9.1.910.010.0.08.19.09.1
Affected range stops below 10.0.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 10.1.* (unaffected)
Affected range stops below 8.1.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.9, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.1 Innovation (unaffected)
Vendor states this is fixed in 2.2 all (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

8.8HIGHpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-120CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card