CVE-2021-3052

PAN-OS: Reflected Cross-Site Scripting (XSS) in Web Interface

MEDIUM
5.4
CVSS Score
Published: September 8, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 04:04 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.6%

Description

A reflected cross-site scripting (XSS) vulnerability in the Palo Alto Network PAN-OS web interface enables an authenticated network-based attacker to mislead another authenticated PAN-OS administrator to click on a specially crafted link that performs arbitrary actions in the PAN-OS web interface as the targeted authenticated administrator. This issue impacts: PAN-OS 8.1 versions earlier than 8.1.20; PAN-OS 9.0 versions earlier than 9.0.14; PAN-OS 9.1 versions earlier than 9.1.10; PAN-OS 10.0 versions earlier than 10.0.2. This issue does not affect Prisma Access.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.0.210.0.0 ≤ v < 10.0.28.1 ≤ v < 8.1.208.1.0 ≤ v < 8.1.209.0 ≤ v < 9.0.149.0.0 ≤ v < 9.0.149.1 ≤ v < 9.1.109.1.0 ≤ v < 9.1.1010.08.19.09.1
Affected range stops below 10.0.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 10.1.* (unaffected)
Affected range stops below 8.1.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.10, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card