CVE-2021-3050

PAN-OS: OS Command Injection Vulnerability in Web Interface

HIGH
8.8
CVSS Score
Published: August 11, 2021 at 05:10 PM UTC
Updated: June 17, 2026 at 04:04 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%

Description

An OS command injection vulnerability in the Palo Alto Networks PAN-OS web interface enables an authenticated administrator to execute arbitrary OS commands to escalate privileges. This issue impacts: PAN-OS 9.0 version 9.0.10 through PAN-OS 9.0.14; PAN-OS 9.1 version 9.1.4 through PAN-OS 9.1.10; PAN-OS 10.0 version 10.0.7 and earlier PAN-OS 10.0 versions; PAN-OS 10.1 version 10.1.0 through PAN-OS 10.1.1. Prisma Access firewalls and firewalls running PAN-OS 8.1 versions are not impacted by this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0.0 ≤ v < 10.0*10.0.0 ≤ v < 10.0.810.1.0 ≤ v < 10.1*10.1.0 ≤ v < 10.1.29.0.0 ≤ v < 9.0.159.0.10 ≤ v < 9.0*9.1.0 ≤ v < 9.1.119.1.4 ≤ v < 9.1*10.0.010.1.09.0.109.1.4
Affected range stops below 10.0*, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1*, so it looks safe — our inference, not a vendor statement
Affected range stops below 10.1.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.1.* (unaffected)
Affected range stops below 9.0*, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1*, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.11, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

8.8HIGHpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card