CVE-2021-29625

XSS in doc_link

MEDIUM
6.1
CVSS Score
Published: May 19, 2021 at 09:35 PM UTC
Updated: June 17, 2026 at 03:48 AM UTC
2 products affected across 2 vendorsAdminerAdminer

Using adminer by vrana?

Get instant alerts when new vulnerabilities affect adminer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 10%

Description

Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.6.1 ≤ v < 4.8.1
Affected range stops below 4.8.1, so it looks safe — our inference, not a vendor statement
60%
v < 4.8.1
Affected range stops below 4.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card