CVE-2021-29510

Use of "infinity" as an input to datetime and date fields causes infinite loop in pydantic

HIGH
7.5
CVSS Score
Published: May 13, 2021 at 06:55 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
3 products affected across 3 vendorsFedoraPydanticPydantic

Using pydantic by samuelcolvin?

Get instant alerts when new vulnerabilities affect pydantic - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1.0%

Description

Pydantic is a data validation and settings management using Python type hinting. In affected versions passing either `'infinity'`, `'inf'` or `float('inf')` (or their negatives) to `datetime` or `date` fields causes validation to run forever with 100% CPU usage (on one CPU). Pydantic has been patched with fixes available in the following versions: v1.8.2, v1.7.4, v1.6.2. All these versions are available on pypi(https://pypi.org/project/pydantic/#history), and will be available on conda-forge(https://anaconda.org/conda-forge/pydantic) soon. See the changelog(https://pydantic-docs.helpmanual.io/) for details. If you absolutely can't upgrade, you can work around this risk using a validator(https://pydantic-docs.helpmanual.io/usage/validators/) to catch these values. This is not an ideal solution (in particular you'll need a slightly different function for datetimes), instead of a hack like this you should upgrade pydantic. If you are not using v1.8.x, v1.7.x or v1.6.x and are unable to upgrade to a fixed version of pydantic, please create an issue at https://github.com/samuelcolvin/pydantic/issues requesting a back-port, and we will endeavour to release a patch for earlier versions of pydantic.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.6.21.7 ≤ v < 1.7.41.8 ≤ v < 1.8.2
v < 1.6.2v < 1.7.4v < 1.8.2
Affected range stops below 1.6.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.7.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.8.2, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-835

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card