CVE-2021-29506

Navigate endpoint is vulnerable to regex injection that may lead to Denial of Service.

MEDIUM
6.5
CVSS Score
Published: May 13, 2021 at 06:15 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
1 product affected across 1 vendorGraphhopper

Using graphhopper by graphhopper?

Get instant alerts when new vulnerabilities affect graphhopper - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 1%

Description

GraphHopper is an open-source Java routing engine. In GrassHopper from version 2.0 and before version 2.4, there is a regular expression injection vulnerability that may lead to Denial of Service. This has been patched in 2.4 and 3.0 See this pull request for the fix: https://github.com/graphhopper/graphhopper/pull/2304

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.42.0 ≤ v < 2.4
Affected range stops below 2.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card