CVE-2021-29478

Vulnerability in the COPY command for large intsets

HIGH
8.8
CVSS Score
Published: May 4, 2021 at 04:00 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
2 products affected across 2 vendorsFedoraRedis

Using redis by redis?

Get instant alerts when new vulnerabilities affect redis - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 4%

Description

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis 6.2 before 6.2.3 could be exploited to corrupt the heap and potentially result with remote code execution. Redis 6.0 and earlier are not directly affected by this issue. The problem is fixed in version 6.2.3. An additional workaround to mitigate the problem without patching the `redis-server` executable is to prevent users from modifying the `set-max-intset-entries` configuration parameter. This can be done using ACL to restrict unprivileged users from using the `CONFIG SET` command.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.2.36.2.0 ≤ v < 6.2.3
Affected range stops below 6.2.3, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-190

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card