CVE-2021-29477

Vulnerability in the STRALGO LCS command

HIGH
8.8
CVSS Score
Published: May 4, 2021 at 03:15 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
2 products affected across 2 vendorsFedoraRedis

Using redis by redis?

Get instant alerts when new vulnerabilities affect redis - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 4%

Description

Redis is an open source (BSD licensed), in-memory data structure store, used as a database, cache, and message broker. An integer overflow bug in Redis version 6.0 or newer could be exploited using the `STRALGO LCS` command to corrupt the heap and potentially result with remote code execution. The problem is fixed in version 6.2.3 and 6.0.13. An additional workaround to mitigate the problem without patching the redis-server executable is to use ACL configuration to prevent clients from using the `STRALGO LCS` command.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.0.13v < 6.2.36.0.0 ≤ v < 6.0.136.2.0 ≤ v < 6.2.3
Affected range stops below 6.0.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.3, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-190

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card