CVE-2021-29476

Insecure Deserialization of untrusted data in rmccue/requests

CRITICAL
9.8
CVSS Score
Published: April 27, 2021 at 08:55 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
1 product affected across 1 vendorRequests

Using Requests by WordPress?

Get instant alerts when new vulnerabilities affect Requests - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 2%

Description

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Requests· WordPresswordpress-plugin
95%
Affected range stops below 1.8.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (2)

CVSS

9.8CRITICALGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card