CVE-2021-29450

WordPress Authenticated disclosure of password-protected posts and pages

MEDIUM
4.3
CVSS Score
Published: April 15, 2021 at 09:20 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
2 products affected across 2 vendorsDebian LinuxWordPress

Using wordpress-develop by WordPress?

Get instant alerts when new vulnerabilities affect wordpress-develop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 2%

Description

Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.7.14.7 ≤ v < 5.7.1
Affected range stops below 5.7.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card