CVE-2021-29447

WordPress Authenticated XXE attack when installation is running PHP 8

MEDIUM
6.5
CVSS Score
Published: April 15, 2021 at 09:10 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
2 products affected across 2 vendorsDebian LinuxWordPress

Using wordpress-develop by WordPress?

Get instant alerts when new vulnerabilities affect wordpress-develop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 86%

Description

Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.7.15.6.0 ≤ v < 5.7.1
Affected range stops below 5.7.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-611

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card