CVE-2021-29435

Cross-Site Request Forgery (CSRF) in trestle-auth

MEDIUM
6.5
CVSS Score
Published: April 13, 2021 at 05:00 PM UTC
Updated: June 17, 2026 at 03:47 AM UTC
2 products affected across 2 vendorsTrestle AuthAuth Project Trestle Auth

Using trestle-auth by TrestleAdmin?

Get instant alerts when new vulnerabilities affect trestle-auth - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.7%

Description

trestle-auth is an authentication plugin for the Trestle admin framework. A vulnerability in trestle-auth versions 0.4.0 and 0.4.1 allows an attacker to create a form that will bypass Rails' built-in CSRF protection when submitted by a victim with a trestle-auth admin session. This potentially allows an attacker to alter protected data, including admin account credentials. The vulnerability has been fixed in trestle-auth 0.4.2 released to RubyGems.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.4.2
Affected range stops below 0.4.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card