CVE-2021-28806

DOM-Based XSS Vulnerability in QTS and QuTS hero

MEDIUM
5.4
CVSS Score
Published: June 3, 2021 at 02:45 AM UTC
Updated: June 17, 2026 at 03:46 AM UTC
3 products affected across 1 vendorQTSQuTS heroQuTScloud

Using QTS by QNAP Systems Inc.?

Get instant alerts when new vulnerabilities affect QTS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.5%

Description

A DOM-based XSS vulnerability has been reported to affect QNAP NAS running QTS and QuTS hero. If exploited, this vulnerability allows attackers to inject malicious code. This issue affects: QNAP Systems Inc. QTS versions prior to 4.5.3.1652 Build 20210428. QNAP Systems Inc. QuTS hero versions prior to h4.5.2.1638 Build 20210414. QNAP Systems Inc. QuTScloud versions prior to c4.5.5.1656 Build 20210503. This issue does not affect: QNAP Systems Inc. QTS 4.3.6; 4.3.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.5.3.1652v < 4.5.3.1652 Build 20210428
Vendor states this is fixed in 4.3.3 (unaffected)
Vendor states this is fixed in 4.3.6 (unaffected)
Affected range stops below 4.5.3.1652, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.3.1652 Build 20210428, so it looks safe — our inference, not a vendor statement
v < h4.5.2.1638v < h4.5.2.1638 Build 20210414
Affected range stops below h4.5.2.1638, so it looks safe — our inference, not a vendor statement
Affected range stops below h4.5.2.1638 Build 20210414, so it looks safe — our inference, not a vendor statement
v < c4.5.5.1656v < c4.5.5.1656 Build 20210503
Affected range stops below c4.5.5.1656, so it looks safe — our inference, not a vendor statement
Affected range stops below c4.5.5.1656 Build 20210503, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card