CVE-2021-28799

Improper Authorization Vulnerability in HBS 3 (Hybrid Backup Sync)

CRITICAL
9.8
CVSS Score
Published: May 13, 2021 at 02:55 AM UTC
Updated: June 17, 2026 at 03:46 AM UTC
4 products affected across 1 vendorHybrid Backup SyncQTSQuTS hero

Using HBS 3 by QNAP Systems Inc.?

Get instant alerts when new vulnerabilities affect HBS 3 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploitation
CISA KEV
Exploit prediction
EPSS 78%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score78.3%

EPSS (Exploit Prediction Scoring System) estimates a 78.3% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

QNAP NAS running HBS 3 contains an improper authorization vulnerability which can allow remote attackers to log in to a device.

Required Action
Apply updates per vendor instructions.
Ransomware Use
Known
Added to KEV
Mar 31, 2022
Remediation Due
Apr 21, 2022
1654 days overdue

Description

An improper authorization vulnerability has been reported to affect QNAP NAS running HBS 3 (Hybrid Backup Sync. ) If exploited, the vulnerability allows remote attackers to log in to a device. This issue affects: QNAP Systems Inc. HBS 3 versions prior to v16.0.0415 on QTS 4.5.2; versions prior to v3.0.210412 on QTS 4.3.6; versions prior to v3.0.210411 on QTS 4.3.4; versions prior to v3.0.210411 on QTS 4.3.3; versions prior to v16.0.0419 on QuTS hero h4.5.1; versions prior to v16.0.0419 on QuTScloud c4.5.1~c4.5.4. This issue does not affect: QNAP Systems Inc. HBS 2 . QNAP Systems Inc. HBS 1.3 .

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 16.0.0415v < 16.0.0419v < 3.0.210411v < 3.0.210412v < v16.0.0415v < v16.0.0419v < v3.0.210411v < v3.0.210412
Vendor states this is fixed in 1.3 (unaffected)
Affected range stops below 16.0.0415, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.0.0419, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2 (unaffected)
Affected range stops below 3.0.210411, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.0.210412, so it looks safe — our inference, not a vendor statement
Affected range stops below v16.0.0415, so it looks safe — our inference, not a vendor statement
Affected range stops below v16.0.0419, so it looks safe — our inference, not a vendor statement
Affected range stops below v3.0.210411, so it looks safe — our inference, not a vendor statement
Affected range stops below v3.0.210412, so it looks safe — our inference, not a vendor statement
qnap-qts (environment) · qnap-quts-hero (environment) · qnap-qutscloud (environment)
80%
All versions
All versions
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

US Government Resource
Source: 134c704f-9b21-4f2e-91b3-4a467353bcc0
https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-28799

SSVC — Action Prioritization

SSVCActiveAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-285NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card