CVE-2021-28706

HIGH
8.6
CVSS Score
Published: November 24, 2021 at 12:00 AM UTC
Updated: June 17, 2026 at 03:46 AM UTC
3 products affected across 3 vendorsDebian LinuxFedoraXen

Using xen by Xen?

Get instant alerts when new vulnerabilities affect xen - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 2%

Description

guests may exceed their designated memory limit When a guest is permitted to have close to 16TiB of memory, it may be able to issue hypercalls to increase its memory allocation beyond the administrator established limit. This is a result of a calculation done with 32-bit precision, which may overflow. It would then only be the overflowed (and hence small) number which gets compared against the established upper bound.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Xen· Xenwordpress-plugin
95%
v ≥ 4.14.x3.2 ≤ v < 4.124.12.x4.13.x4.14.xxen-unstable
Vendor states this is fixed in next of 4.15.x (unaffected)
Vendor states this is fixed in 4.12 (unknown)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card