CVE-2021-27850

Bypass of the fix for CVE-2019-0195

CRITICAL
9.8
CVSS Score
Published: April 15, 2021 at 07:40 AM UTC
Updated: June 17, 2026 at 03:45 AM UTC
1 product affected across 1 vendorTapestry

Using Apache Tapestry by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Tapestry - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 94%

Description

A critical unauthenticated remote code execution vulnerability was found all recent versions of Apache Tapestry. The affected versions include 5.4.5, 5.5.0, 5.6.2 and 5.7.0. The vulnerability I have found is a bypass of the fix for CVE-2019-0195. Recap: Before the fix of CVE-2019-0195 it was possible to download arbitrary class files from the classpath by providing a crafted asset file URL. An attacker was able to download the file `AppModule.class` by requesting the URL `http://localhost:8080/assets/something/services/AppModule.class` which contains a HMAC secret key. The fix for that bug was a blacklist filter that checks if the URL ends with `.class`, `.properties` or `.xml`. Bypass: Unfortunately, the blacklist solution can simply be bypassed by appending a `/` at the end of the URL: `http://localhost:8080/assets/something/services/AppModule.class/` The slash is stripped after the blacklist check and the file `AppModule.class` is loaded into the response. This class usually contains the HMAC secret key which is used to sign serialized Java objects. With the knowledge of that key an attacker can sign a Java gadget chain that leads to RCE (e.g. CommonsBeanUtils1 from ysoserial). Solution for this vulnerability: * For Apache Tapestry 5.4.0 to 5.6.1, upgrade to 5.6.2 or later. * For Apache Tapestry 5.7.0, upgrade to 5.7.1 or later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.4.0 ≤ v < 5.6.25.7.0 ≤ v < 5.7.1Apache Tapestry 5.4.5 ≤ v < Apache Tapestry 5.4.0*Apache Tapestry 5.6.2 ≤ v < Apache Tapestry 5.6.0*5.4.55.5.05.6.25.7.0
Affected range stops below 5.6.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.7.1, so it looks safe — our inference, not a vendor statement
Affected range stops below Apache Tapestry 5.4.0*, so it looks safe — our inference, not a vendor statement
Affected range stops below Apache Tapestry 5.6.0*, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card