CVE-2021-25642

Apache Hadoop YARN remote code execution in ZKConfigurationStore of capacity scheduler

HIGH
8.8
CVSS Score
Published: August 25, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 03:42 AM UTC
1 product affected across 1 vendorHadoop

Using Apache Hadoop by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Hadoop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%

Description

ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.9.0 ≤ v ≤ 3.3.32.9.0 ≤ v < 2.10.23.0.0 ≤ v < 3.2.43.3.0 ≤ v < 3.3.4
Affected range stops below 2.10.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card