CVE-2021-23841

Null pointer deref in X509_issuer_and_serial_hash()

MEDIUM
5.9
CVSS Score
Published: February 16, 2021 at 04:55 PM UTC
Updated: June 17, 2026 at 03:38 AM UTC
23 products affected across 7 vendorsmacOSDebian LinuxiPhone OS

Using OpenSSL by OpenSSL?

Get instant alerts when new vulnerabilities affect OpenSSL - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 7%
SSVC
No known exploit

Description

The OpenSSL public API function X509_issuer_and_serial_hash() attempts to create a unique hash value based on the issuer and serial number data contained within an X509 certificate. However it fails to correctly handle any errors that may occur while parsing the issuer field (which might occur if the issuer field is maliciously constructed). This may subsequently result in a NULL pointer deref and a crash leading to a potential denial of service attack. The function X509_issuer_and_serial_hash() is never directly called by OpenSSL itself so applications are only vulnerable if they use this function directly and they use it on certificates that may have been obtained from untrusted sources. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 14.6
Affected range stops below 14.6, so it looks safe — our inference, not a vendor statement
v < 14.6
Affected range stops below 14.6, so it looks safe — our inference, not a vendor statement
11.1 ≤ v < 11.4
Affected range stops below 11.4, so it looks safe — our inference, not a vendor statement
v < 14.1.1
Affected range stops below 14.1.1, so it looks safe — our inference, not a vendor statement
All versions
All versions
1.0.2 ≤ v < 1.0.2y1.1.1 ≤ v < 1.1.1j
Vendor states this is fixed in 1.0.2y (unaffected)
Vendor states this is fixed in 1.1.1j (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-476

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card