CVE-2021-23840

Integer overflow in CipherUpdate

HIGH
7.5
CVSS Score
Published: February 16, 2021 at 04:55 PM UTC
Updated: June 17, 2026 at 03:38 AM UTC
27 products affected across 7 vendorsDebian LinuxMySQL ServerOpenSSL

Using OpenSSL by OpenSSL?

Get instant alerts when new vulnerabilities affect OpenSSL - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 51%
SSVC
No known exploit

Description

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform. In such cases the return value from the function call will be 1 (indicating success), but the output length value will be negative. This could cause applications to behave incorrectly or crash. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < xcp2410v < xcp3110
Affected range stops below xcp2410, so it looks safe — our inference, not a vendor statement
Affected range stops below xcp3110, so it looks safe — our inference, not a vendor statement
fujitsu-m10-1 (same device)
v < xcp2410v < xcp3110
Affected range stops below xcp2410, so it looks safe — our inference, not a vendor statement
Affected range stops below xcp3110, so it looks safe — our inference, not a vendor statement
fujitsu-m10-4 (same device)
v < xcp2410v < xcp3110
Affected range stops below xcp2410, so it looks safe — our inference, not a vendor statement
Affected range stops below xcp3110, so it looks safe — our inference, not a vendor statement
fujitsu-m10-4s (same device)
v < xcp2410v < xcp3110
Affected range stops below xcp2410, so it looks safe — our inference, not a vendor statement
Affected range stops below xcp3110, so it looks safe — our inference, not a vendor statement
fujitsu-m12-1 (same device)
v < xcp2410v < xcp3110
Affected range stops below xcp2410, so it looks safe — our inference, not a vendor statement
Affected range stops below xcp3110, so it looks safe — our inference, not a vendor statement
fujitsu-m12-2 (same device)
v < xcp2410v < xcp3110
Affected range stops below xcp2410, so it looks safe — our inference, not a vendor statement
Affected range stops below xcp3110, so it looks safe — our inference, not a vendor statement
fujitsu-m12-2s (same device)
10.0.0 ≤ v ≤ 10.12.010.13.0 ≤ v < 10.24.012.0.0 ≤ v ≤ 12.12.012.13.0 ≤ v < 12.21.014.0.0 ≤ v ≤ 14.14.015.0.0 ≤ v < 15.10.014.15.0
Affected range stops below 10.24.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.21.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.10.0, so it looks safe — our inference, not a vendor statement
1.0.2 ≤ v < 1.0.2y1.1.1 ≤ v < 1.1.1j
Vendor states this is fixed in 1.0.2y (unaffected)
Vendor states this is fixed in 1.1.1j (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-190

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card