CVE-2021-22915

CRITICAL
9.8
CVSS Score
Published: June 11, 2021 at 03:49 PM UTC
Updated: June 17, 2026 at 03:38 AM UTC
2 products affected across 2 vendorsFedoraNextcloud/server

Using Nextcloud Server by N/A?

Get instant alerts when new vulnerabilities affect Nextcloud Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 2%

Description

Nextcloud server before 19.0.11, 20.0.10, 21.0.2 is vulnerable to brute force attacks due to lack of inclusion of IPv6 subnets in rate-limiting considerations. This could potentially result in an attacker bypassing rate-limit controls such as the Nextcloud brute-force protection.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 19.0.1120.0.0 ≤ v < 20.0.1021.0.0 ≤ v < 21.0.2
Vendor states this is fixed in 19.0.11 (unaffected)
Affected range stops below 20.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.0.2, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-307

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card