CVE-2021-22910

CRITICAL
9.8
CVSS Score
Published: August 9, 2021 at 12:27 PM UTC
Updated: June 17, 2026 at 03:38 AM UTC
1 product affected across 1 vendorChat Rocket Chat

Using Rocket.Chat server by N/A?

Get instant alerts when new vulnerabilities affect Rocket.Chat server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 2%

Description

A sanitization vulnerability exists in Rocket.Chat server versions <3.13.2, <3.12.4, <3.11.4 that allowed queries to an endpoint which could result in a NoSQL injection, potentially leading to RCE.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.11.43.12.0 ≤ v < 3.12.43.13.0 ≤ v < 3.13.2Fixed versions: 3.13.2, 3.12.4, 3.11.4
Affected range stops below 3.11.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.12.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.13.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (2)

x_refsource_MISCExploitMailing ListThird Party Advisory
https://hackerone.com/reports/1130874

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-75NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card