CVE-2021-22904

HIGH
7.5
CVSS Score
Published: June 11, 2021 at 03:49 PM UTC
Updated: June 17, 2026 at 03:37 AM UTC
1 product affected across 1 vendorRails

Using https://github.com/rails/rails by N/A?

Get instant alerts when new vulnerabilities affect https://github.com/rails/rails - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 5%

Description

The actionpack ruby gem before 6.1.3.2, 6.0.3.7, 5.2.4.6, 5.2.6 suffers from a possible denial of service vulnerability in the Token Authentication logic in Action Controller due to a too permissive regular expression. Impacted code uses `authenticate_or_request_with_http_token` or `authenticate_with_http_token` for request authentication.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.2.4.65.2.5 ≤ v < 5.2.66.0.0 ≤ v < 6.0.3.76.1.0 ≤ v < 6.1.3.2
Affected range stops below 5.2.4.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.3.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.1.3.2 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card