CVE-2021-22880

HIGH
7.5
CVSS Score
Published: February 11, 2021 at 04:11 PM UTC
Updated: June 17, 2026 at 03:37 AM UTC
2 products affected across 2 vendorsFedoraRails

Using https://github.com/rails/rails by N/A?

Get instant alerts when new vulnerabilities affect https://github.com/rails/rails - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 4%

Description

The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.2.0 ≤ v < 5.2.4.56.0.0 ≤ v < 6.0.3.56.1.0 ≤ v < 6.1.2.1
Affected range stops below 5.2.4.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.3.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 6.1.2.1 (unaffected)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card