CVE-2021-21684

MEDIUM
6.1
CVSS Score
Published: October 6, 2021 at 10:10 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
1 product affected across 1 vendorGit

Using Jenkins Git Plugin by Jenkins project?

Get instant alerts when new vulnerabilities affect Jenkins Git Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 1%

Description

Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause, resulting in a stored cross-site scripting (XSS) vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Git· Jenkinsjenkins-plugin
95%
v ≤ 4.8.2
Vendor states this is fixed in 4.3.1 (unaffected)
Vendor states this is fixed in 4.7.1.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-116

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card