CVE-2021-21391

Regular expression Denial of Service in multiple packages

MEDIUM
6.5
CVSS Score
Published: April 29, 2021 at 12:20 AM UTC
Updated: June 17, 2026 at 03:35 AM UTC
9 products affected across 1 vendorCKEDITOR5 Markdown GfmCKEDITOR5 EngineCKEDITOR5 Widget

Using ckeditor5 by ckeditor?

Get instant alerts when new vulnerabilities affect ckeditor5 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 2%

Description

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement
v < 27.0.0
Affected range stops below 27.0.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card