CVE-2021-21379

It's possible to execute anything with the rights of the author of a macro which uses the {{wikimacrocontent}} macro

MEDIUM
5.4
CVSS Score
Published: March 12, 2021 at 05:30 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
1 product affected across 1 vendorXwiki

Using xwiki-platform by xwiki?

Get instant alerts when new vulnerabilities affect xwiki-platform - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.5%

Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions of XWiki Platform, the `{{wikimacrocontent}}` executes the content with the rights of the wiki macro author instead of the caller of that wiki macro. This makes possible to inject scripts through it and they will be executed with the rights of the wiki macro (very often a user which has Programming rights). Fortunately, no such macro exists by default in XWiki Standard but one could have been created or installed with an extension. This vulnerability has been patched in versions XWiki 12.6.3, 11.10.11 and 12.8-rc-1. There is no easy workaround other than disabling the affected macros. Inserting content in a safe way or knowing what is the user who called the wiki macro is not easy.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 11.10.11v < 12.6.3v < 12.8-rc-111.4 ≤ v < 11.10.1112.0 ≤ v < 12.6.312.7 ≤ v ≤ 12.7.1
Affected range stops below 11.10.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.6.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.8-rc-1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-281

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card