CVE-2021-21365

Cross-Site Scripting in Content Rendering

MEDIUM
5.4
CVSS Score
Published: April 27, 2021 at 07:30 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
2 products affected across 2 vendorsTYPO3TYPO3

Using bootstrap_package by benjaminkott?

Get instant alerts when new vulnerabilities affect bootstrap_package - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.9%

Description

Bootstrap Package is a theme for TYPO3. It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability. Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix. Update to version 7.1.2, 8.0.8, 9.1.4, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described. Updated version are available from the TYPO3 extension manager, Packagist and at https://extensions.typo3.org/extension/download/bootstrap_package/.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 7.1.210.0.0 ≤ v < 10.0.1011.0.0 ≤ v < 11.0.38.0.0 ≤ v < 8.0.89.0.0 ≤ v < 9.0.49.1.0 ≤ v < 9.1.3
Affected range stops below 10.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.3, so it looks safe — our inference, not a vendor statement
v < 10.0.10v < 11.0.3v < 7.1.2v < 8.0.8v < 9.0.4v < 9.1.3
Affected range stops below 10.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

5.4MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card