CVE-2021-21334

environment variable leak

MEDIUM
6.3
CVSS Score
Published: March 10, 2021 at 09:30 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
3 products affected across 3 vendorsFedoraContainerdContainerd

Using containerd by containerd?

Get instant alerts when new vulnerabilities affect containerd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 2%

Description

In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.3.101.4.0 ≤ v < 1.4.4
Affected range stops below 1.3.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.4, so it looks safe — our inference, not a vendor statement
v < 1.3.10v < 1.4.4
Affected range stops below 1.3.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.4, so it looks safe — our inference, not a vendor statement

CVSS

6.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-668

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card