CVE-2021-21311

SSRF in adminer

HIGH
7.2
CVSS Score
Published: February 11, 2021 at 08:55 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
3 products affected across 3 vendorsDebian LinuxAdminerAdminer

Using adminer by vrana?

Get instant alerts when new vulnerabilities affect adminer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploitation
CISA KEV
Exploit prediction
EPSS 98%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score98.5%

EPSS (Exploit Prediction Scoring System) estimates a 98.5% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Adminer contains a server-side request forgery vulnerability that, when exploited, allows a remote attacker to obtain potentially sensitive information.

Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Sep 29, 2025
Remediation Due
Oct 20, 2025
376 days overdue

Description

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.0.0 ≤ v < 4.7.9
Affected range stops below 4.7.9, so it looks safe — our inference, not a vendor statement
60%
v < 4.7.9
Affected range stops below 4.7.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.2HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card