CVE-2021-21307

Remote Code Exploit in Lucee Admin

CRITICAL
9.8
CVSS Score
Published: February 11, 2021 at 06:20 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
1 product affected across 1 vendorLucee Server

Using Lucee by lucee?

Get instant alerts when new vulnerabilities affect Lucee - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 89%

Description

Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.3.5.96v < 5.3.6.68v < 5.3.7.475.3.5.00 ≤ v < 5.3.5.965.3.6.00 ≤ v < 5.3.6.685.3.7.00 ≤ v < 5.3.7.47
Affected range stops below 5.3.5.96, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.6.68, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.7.47, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card