CVE-2021-21306

Denial of Service in Marked

HIGH
7.5
CVSS Score
Published: February 8, 2021 at 09:20 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
2 products affected across 2 vendorsMarkedMarked

Using marked by markedjs?

Get instant alerts when new vulnerabilities affect marked - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 2%

Description

Marked is an open-source markdown parser and compiler (npm package "marked"). In marked from version 1.1.1 and before version 2.0.0, there is a Regular expression Denial of Service vulnerability. This vulnerability can affect anyone who runs user generated code through marked. This vulnerability is fixed in version 2.0.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.1.1 ≤ v < 2.0.0
Affected range stops below 2.0.0, so it looks safe — our inference, not a vendor statement
v < 2.0.0
Affected range stops below 2.0.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card