CVE-2021-21299

Multiple Transfer-Encoding headers misinterprets request payload

HIGH
8.1
CVSS Score
Published: February 11, 2021 at 06:00 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
2 products affected across 2 vendorsHyperHyper

Using hyper by hyperium?

Get instant alerts when new vulnerabilities affect hyper - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 5%

Description

hyper is an open-source HTTP library for Rust (crates.io). In hyper from version 0.12.0 and before versions 0.13.10 and 0.14.3 there is a vulnerability that can enable a request smuggling attack. The HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". To determine if vulnerable, all these things must be true: 1) Using hyper as an HTTP server (the client is not affected), 2) Using HTTP/1.1 (HTTP/2 does not use transfer-encoding), 3) Using a vulnerable HTTP proxy upstream to hyper. If an upstream proxy correctly rejects the illegal transfer-encoding headers, the desync attack cannot succeed. If there is no proxy upstream of hyper, hyper cannot start the desync attack, as the client will repair the headers before forwarding. This is fixed in versions 0.14.3 and 0.13.10. As a workaround one can take the following options: 1) Reject requests that contain a `transfer-encoding` header, 2) Ensure any upstream proxy handles `transfer-encoding` correctly.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.12.0 ≤ v < 0.13.100.14.0 ≤ v < 0.14.3
Affected range stops below 0.13.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.14.3, so it looks safe — our inference, not a vendor statement
v < 0.13.10v < 0.14.3
Affected range stops below 0.13.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.14.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-444

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card