CVE-2021-21281

Buffer overflow due to unvalidated TCP data offset

CRITICAL
9.8
CVSS Score
Published: June 18, 2021 at 08:25 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
1 product affected across 1 vendorContiki-NG

Using contiki-ng by contiki-ng?

Get instant alerts when new vulnerabilities affect contiki-ng - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 0.9%

Description

Contiki-NG is an open-source, cross-platform operating system for internet of things devices. A buffer overflow vulnerability exists in Contiki-NG versions prior to 4.6. After establishing a TCP socket using the tcp-socket library, it is possible for the remote end to send a packet with a data offset that is unvalidated. The problem has been patched in Contiki-NG 4.6. Users can apply the patch for this vulnerability out-of-band as a workaround.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.6
Affected range stops below 4.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-120

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card