CVE-2021-21258

XSS injection in ajax/kanban

MEDIUM
5.4
CVSS Score
Published: March 2, 2021 at 07:45 PM UTC
Updated: June 17, 2026 at 03:35 AM UTC
1 product affected across 1 vendorGlpi

Using glpi by glpi-project?

Get instant alerts when new vulnerabilities affect glpi - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.6%

Description

GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 9.5.49.5.0 ≤ v < 9.5.4
Affected range stops below 9.5.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card