CVE-2021-20280

MEDIUM
5.4
CVSS Score
Published: March 15, 2021 at 09:35 PM UTC
Updated: June 17, 2026 at 03:33 AM UTC
2 products affected across 2 vendorsFedoraMoodle

Using moodle by N/A?

Get instant alerts when new vulnerabilities affect moodle - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 1%

Description

Text-based feedback answers required additional sanitizing to prevent stored XSS and blind SSRF risks in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.10.0 ≤ v < 3.10.23.5.0 ≤ v < 3.5.173.8.0 ≤ v < 3.8.83.9.0 ≤ v < 3.9.5
Vendor states this is fixed in 3.10.2 (unaffected)
Affected range stops below 3.5.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.5, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card