CVE-2021-0287

Junos OS and Junos OS Evolved: RPD could crash in SR-ISIS/MPLS environment due to a flap of an ISIS link in the network

MEDIUM
6.5
CVSS Score
Published: July 15, 2021 at 08:01 PM UTC
Updated: June 17, 2026 at 03:29 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.4%

Description

In a Segment Routing ISIS (SR-ISIS)/MPLS environment, on Juniper Networks Junos OS and Junos OS Evolved devices, configured with ISIS Flexible Algorithm for Segment Routing and sensor-based statistics, a flap of a ISIS link in the network, can lead to a routing process daemon (RPD) crash and restart, causing a Denial of Service (DoS). Continued link flaps will create a sustained Denial of Service (DoS) condition. This issue affects: Juniper Networks Junos OS: 19.4 versions prior to 19.4R1-S4, 19.4R3-S2; 20.1 versions prior to 20.1R2-S1, 20.1R3; 20.2 versions prior to 20.2R2-S2, 20.2R3; 20.3 versions prior to 20.3R2; Juniper Networks Junos OS Evolved: 20.3-EVO versions prior to 20.3R2-EVO; 20.4-EVO versions prior to 20.4R2-EVO. This issue does not affect: Juniper Networks Junos OS releases prior to 19.4R1. Juniper Networks Junos OS Evolved releases prior to 19.4R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 19.4*, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 19.4R1 (unaffected)
Affected range stops below 20.1R2-S1, 20.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R2-S2, 20.2R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R2, so it looks safe — our inference, not a vendor statement
19.4R1-EVO ≤ v < 19.4*20.1R1-EVO ≤ v < 20.1*20.2R1-EVO ≤ v < 20.2*20.3 ≤ v < 20.3R2-EVO20.4 ≤ v < 20.4R2-EVO19.4R1-EVO20.1R1-EVO20.2R1-EVO20.320.4
Affected range stops below 19.4*, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 19.4R1-EVO (unaffected)
Affected range stops below 20.1*, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2*, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA11189

CVSS

6.5MEDIUMjuniper
Attack Vector
ADJACENT_NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-754

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card