CVE-2021-0236

Junos OS: A specific BGP VPNv6 flowspec message causes routing protocol daemon (rpd) process to crash with a core.

MEDIUM
6.5
CVSS Score
Published: April 22, 2021 at 07:37 PM UTC
Updated: June 17, 2026 at 03:29 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.8%

Description

Due to an improper check for unusual or exceptional conditions in Juniper Networks Junos OS and Junos OS Evolved the Routing Protocol Daemon (RPD) service, upon receipt of a specific matching BGP packet meeting a specific term in the flowspec configuration, crashes and restarts causing a Denial of Service (DoS). Continued receipt and processing of this packet will create a sustained Denial of Service (DoS) condition. This issue affects only Multiprotocol BGP (MP-BGP) VPNv6 FlowSpec deployments. This issue affects: Juniper Networks Junos OS: 18.4 versions prior to 18.4R1-S8, 18.4R2-S7, 18.4R3-S7; 19.1 versions prior to 19.1R2-S2, 19.1R3-S4; 19.2 versions prior to 19.2R1-S6, 19.2R3-S2; 19.3 versions prior to 19.3R3-S2; 19.4 versions prior to 19.4R2-S4, 19.4R3-S1; 20.1 versions prior to 20.1R2, 20.1R3; 20.2 versions prior to 20.2R2, 20.2R3; 20.3 versions prior to 20.3R1-S1, 20.3R2. Juniper Networks Junos OS Evolved: All versions after 18.4R1-EVO prior to 20.3R2-EVO. This issue does not affect: Juniper Networks Junos OS versions prior to 18.4R1. Juniper Networks Junos OS Evolved versions prior to 18.4R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 18.4R1 (unaffected)
Affected range stops below 18.4R1-S8, 18.4R2-S7, 18.4R3-S7, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.1R2-S2, 19.1R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.2R1-S6, 19.2R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.4R2-S4, 19.4R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.1R2, 20.1R3, 20.1R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.2R2, 20.2R3, 20.2R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.3R1-S1, 20.3R2, 20.3R2-EVO, so it looks safe — our inference, not a vendor statement
20.3-EVO ≤ v < 20.3R2-EVO20.3-EVO
Vendor states this is fixed in 18.4R1-EVO (unaffected)
Affected range stops below 20.3R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_MISCVendor Advisory
https://kb.juniper.net/JSA11131

CVSS

6.5MEDIUMjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-754

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card