CVE-2020-8934

Site Kit by Google plugin for WordPress

MEDIUM
4.3
CVSS Score
Published: July 7, 2023 at 11:46 AM UTC
Updated: June 17, 2026 at 03:27 AM UTC
1 product affected across 1 vendorSite Kit

Using Site Kit By Google by Google?

Get instant alerts when new vulnerabilities affect Site Kit By Google - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

The Site Kit by Google plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 1.8.0 This is due to the lack of capability checks on the admin_enqueue_scripts action which displays the connection key. This makes it possible for authenticated attackers with any level of access obtaining owner access to a site in the Google Search Console. We recommend upgrading to V1.8.1 or above.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Site Kit· Googlewordpress-plugin
95%
v ≤ 1.8.0v < 1.8.1
Affected range stops below 1.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMGoogle
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-252

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card