CVE-2020-8904

Arbitrary trusted memory overwrite vulnerability in Asylo

CRITICAL
9.6
CVSS Score
Published: August 12, 2020 at 06:20 PM UTC
Updated: June 17, 2026 at 03:27 AM UTC
1 product affected across 1 vendorAsylo

Using Asylo by Google LLC?

Get instant alerts when new vulnerabilities affect Asylo - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.6
Exploit prediction
EPSS 0.2%

Description

An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0. As the ecall_restore function fails to validate the range of the output_len pointer, an attacker can manipulate the tmp_output_len value and write to an arbitrary location in the trusted (enclave) memory. We recommend updating Asylo to version 0.6.0 or later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.6.0stable ≤ v < 0.6.0stable
Affected range stops below 0.6.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-823CWE-119

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card