CVE-2020-8277

HIGH
7.5
CVSS Score
Published: November 19, 2020 at 12:32 AM UTC
Updated: June 17, 2026 at 03:26 AM UTC
8 products affected across 4 vendorsFedoraJD Edwards EnterpriseOne ToolsNode.js

Using Node by NodeJS?

Get instant alerts when new vulnerabilities affect Node - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 54%

Description

A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.16.0
Affected range stops below 1.16.0, so it looks safe — our inference, not a vendor statement
11.0 ≤ v < 11.*12.0 ≤ v < 12.19.112.16.3 ≤ v < 12.19.113.0 ≤ v < 13.*14.0 ≤ v < 14.15.114.13.0 ≤ v < 14.15.115.0 ≤ v < 15.2.115.0.0 ≤ v < 15.2.14.0 ≤ v < 4.*5.0 ≤ v < 5.*6.0 ≤ v < 6.*7.0 ≤ v < 7.*8.0 ≤ v < 8.*9.0 ≤ v < 9.*11.012.013.014.015.04.05.06.07.08.09.0
Affected range stops below 11.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.19.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.15.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.*, so it looks safe — our inference, not a vendor statement
v < 21.1.2
Affected range stops below 21.1.2, so it looks safe — our inference, not a vendor statement
v < 9.2.6.0
Affected range stops below 9.2.6.0, so it looks safe — our inference, not a vendor statement
v ≤ 8.0.23

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card