CVE-2020-8244

MEDIUM
6.5
CVSS Score
Published: August 30, 2020 at 01:43 PM UTC
Updated: June 17, 2026 at 03:26 AM UTC
2 products affected across 2 vendorsDebian LinuxBufferlist

Using bl by N/A?

Get instant alerts when new vulnerabilities affect bl - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 2%

Description

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.2.32.0.0 ≤ v < 2.2.13.0.0 ≤ v < 3.0.14.0.0 ≤ v < 4.0.3
Affected range stops below 1.2.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.0.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 4.0.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (2)

x_refsource_MISCExploitPatchThird Party Advisory
https://hackerone.com/reports/966347
Mailing Listx_refsource_MLISTThird Party Advisory
https://lists.debian.org/debian-lts-announce/2021/06/msg00028.html

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-126CWE-125

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card