CVE-2020-7943

HIGH
7.5
CVSS Score
Published: March 11, 2020 at 09:56 PM UTC
Updated: June 17, 2026 at 03:25 AM UTC
3 products affected across 1 vendorPuppet EnterprisePuppetPuppetdb

Using Puppet Enterprise 2018.1.x stream by N/A?

Get instant alerts when new vulnerabilities affect Puppet Enterprise 2018.1.x stream - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 8%

Description

Puppet Server and PuppetDB provide useful performance and debugging information via their metrics API endpoints. For PuppetDB this may contain things like hostnames. Puppet Server reports resource names and titles for defined types (which may contain sensitive information) as well as function names and class names. Previously, these endpoints were open to the local network. PE 2018.1.13 & 2019.5.0, Puppet Server 6.9.2 & 5.3.12, and PuppetDB 6.9.1 & 5.2.13 disable trapperkeeper-metrics /v1 metrics API and only allows /v2 access on localhost by default. This affects software versions: Puppet Enterprise 2018.1.x stream prior to 2018.1.13 Puppet Enterprise prior to 2019.5.0 Puppet Server prior to 6.9.2 Puppet Server prior to 5.3.12 PuppetDB prior to 6.9.1 PuppetDB prior to 5.2.13 Resolved in: Puppet Enterprise 2018.1.13 Puppet Enterprise 2019.5.0 Puppet Server 6.9.2 Puppet Server 5.3.12 PuppetDB 6.9.1 PuppetDB 5.2.13

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 5.3.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.11.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.9.2, so it looks safe — our inference, not a vendor statement
v < 2018.1.13v < 2019.5.02018.1.0 ≤ v < 2018.1.152019.0 ≤ v < 2019.7.0Puppet Enterprise 2018.1.13 and 2019.5.0Puppet Server 6.9.2 and 5.3.12PuppetDB 6.9.1 and 5.2.13
Affected range stops below 2018.1.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 2018.1.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 2019.5.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 2019.7.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.10.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.9.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-276NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card