CVE-2020-6304

HIGH
7.5
CVSS Score
Published: January 14, 2020 at 05:52 PM UTC
Updated: June 17, 2026 at 03:23 AM UTC
5 products affected across 1 vendorNetweaver Internet Communication Manager (krnl64uc )Netweaver Internet Communication Manager (krnl32nuc )Netweaver Internet Communication Manager (kernel )

Using SAP NetWeaver Internet Communication Manager (KRNL32NUC) by SAP SE?

Get instant alerts when new vulnerabilities affect SAP NetWeaver Internet Communication Manager (KRNL32NUC) - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%

Description

Improper input validation in SAP NetWeaver Internet Communication Manager (update provided in KRNL32NUC & KRNL32UC 7.21, 7.21EXT, 7.22, 7.22EXT KRNL64NUC & KRNL64UC 7.21, 7.21EXT, 7.22, 7.22EXT, 7.49 KERNEL 7.21, 7.49, 7.53) allows an attacker to prevent users from accessing its services through a denial of service.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 7.21v < 7.22v < 7.49v < 7.537.217.227.497.53
Affected range stops below 7.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.49, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.53, so it looks safe — our inference, not a vendor statement
v < 7.21v < 7.21EXTv < 7.22v < 7.22EXT7.217.21ext7.227.22ext
Affected range stops below 7.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.21EXT, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22EXT, so it looks safe — our inference, not a vendor statement
v < 7.21v < 7.21EXTv < 7.22v < 7.22EXT7.217.21ext7.227.22ext
Affected range stops below 7.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.21EXT, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22EXT, so it looks safe — our inference, not a vendor statement
v < 7.21v < 7.21EXTv < 7.22v < 7.22EXTv < 7.497.217.21ext7.227.22ext7.49
Affected range stops below 7.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.21EXT, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22EXT, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.49, so it looks safe — our inference, not a vendor statement
v < 7.21v < 7.21EXTv < 7.22v < 7.22EXTv < 7.497.217.21ext7.227.22ext7.49
Affected range stops below 7.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.21EXT, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.22EXT, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.49, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card