CVE-2020-5263

Information disclosure through error object

MEDIUM
4.9
CVSS Score
Published: April 9, 2020 at 03:50 PM UTC
Updated: June 17, 2026 at 03:21 AM UTC
1 product affected across 1 vendorAuth0.js

Using auth0.js by auth0?

Get instant alerts when new vulnerabilities affect auth0.js - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.9
Exploit prediction
EPSS 0.9%

Description

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 9.12.38.0.0 ≤ v ≤ 9.13.1
Affected range stops below 9.12.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-522

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card